交换机配置语句switch的功能?

1.在基于IOS的交换机上设置主机名/系统名:

switch(config)# hostname hostname

在基于CLI的交换机上设置主机名/系统名:

switch(enable) set system name name-string2.在基于IOS的交换机上设置登录口令:

switch(config)# enable password level 1 password

在基于CLI的交换机上设置登录口令:

switch(enable) set password

switch(enable) set enalbepass 3.在基于IOS的交换机上设置远程访问:

switch(config)# interface vlan 1

switch(config-if)# ip address ip-address netmask

switch(config-if)# ip default-gateway ip-address

在基于CLI的交换机上设置远程访问:

switch(enable) set interface sc0 ip-address netmask broadcast-address

switch(enable) set interface sc0 vlan

switch(enable) set ip route default gateway 4.在基于IOS的交换机上启用和浏览CDP信息:

switch(config-if)# cdp enable

switch(config-if)# no cdp enable

为了查看Cisco邻接设备的CDP通告信息:

switch# show cdp interface [type modle/port]

switch# show cdp neighbors [type module/port] [detail]

在基于CLI的交换机上启用和浏览CDP信息:

switch(enable) set cdp {enable|disable} module/port

为了查看Cisco邻接设备的CDP通告信息:

switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail] 5.基于IOS的交换机的端口描述:

switch(config-if)# description description-string

基于CLI的交换机的端口描述:

switch(enable)set port name module/number description-string 6.在基于IOS的交换机上设置端口速度:

switch(config-if)# speed{10|100|auto}

在基于CLI的交换机上设置端口速度:

switch(enable) set port speed moudle/number {10|100|auto}

switch(enable) set port speed moudle/number {4|16|auto} 7.在基于IOS的交换机上设置以太网的链路模式:

switch(config-if)# duplex {auto|full|half}

在基于CLI的交换机上设置以太网的链路模式:

switch(enable) set port duplex module/number {full|half} 8.在基于IOS的交换机上配置静态VLAN:

switch# vlan database

switch(vlan)# vlan vlan-num name vla switch(vlan)# exit

switch# configure teriminal

switch(config)# interface interface module/number

switch(config-if)# switchport mode access

switch(config-if)# switchport access vlan vlan-num

switch(config-if)# end

在基于CLI的交换机上配置静态VLAN:

switch(enable) set vlan vlan-num [name name]

switch(enable) set vlan vlan-num mod-num/port-list 9. 在基于IOS的交换机上配置VLAN中继线:

switch(config)# interface interface mod/port

switch(config-if)# switchport mode trunk

switch(config-if)# switchport trunk encapsulation {isl|dotlq}

switch(config-if)# switchport trunk allowed vlan remove vlan-list

switch(config-if)# switchport trunk allowed vlan add vlan-list

在基于CLI的交换机上配置VLAN中继线:

switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]

Vlan-range [isl|dotlq|dotl0|lane|negotiate] 10.在基于IOS的交换机上配置VTP管理域:

switch# vlan database

switch(vlan)# vtp domain domain-name

在基于CLI的交换机上配置VTP管理域:

switch(enable) set vtp [domain domain-name]

11.在基于IOS的交换机上配置VTP 模式:

switch# vlan database

switch(vlan)# vtp domain domain-name

switch(vlan)# vtp {sever|cilent|transparent}

switch(vlan)# vtp password password

在基于CLI的交换机上配置VTP 模式:

switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password] 12. 在基于IOS的交换机上配置VTP版本:

switch# vlan database

switch(vlan)# vtp v2-mode

在基于CLI的交换机上配置VTP版本:

switch(enable) set vtp v2 enable 13. 在基于IOS的交换机上启动VTP剪裁:

switch# vlan database

switch(vlan)# vtp pruning

在基于CL I 的交换机上启动VTP剪裁:

switch(enable) set vtp pruning enable 14.在基于IOS的交换机上配置以太信道:

switch(config-if)# port group group-number [distribution {source|destination}]

在基于CLI的交换机上配置以太信道:

switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto} 15.在基于IOS的交换机上调整根路径成本:

switch(config-if)# spanning-tree [vlan vlan-list] cost cost

在基于CLI的交换机上调整根路径成本: switch(enable) set spantree portcost moudle/port cost

switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list] 16.在基于IOS的交换机上调整端口ID:

switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority

在基于CLI的交换机上调整端口ID:

switch(enable) set spantree portpri {mldule/port}priority

switch(enable) set spantree portvlanpri {module/port}priority [vlans] 17. 在基于IOS的交换机上修改STP时钟:

switch(config)# spanning-tree [vlan vlan-list] hello-time seconds

switch(config)# spanning-tree [vlan vlan-list] forward-time seconds

` switch(config)# spanning-tree [vlan vlan-list] max-age seconds

在基于CLI的交换机上修改STP时钟:

switch(enable) set spantree hello interval[vlan]

switch(enable) set spantree fwddelay delay [vlan]

switch(enable) set spantree maxage agingtiame[vlan] 18. 在基于IOS的交换机端口上启用或禁用Port Fast 特征:

switch(config-if)#spanning-tree portfast

在基于CLI的交换机端口上启用或禁用Port Fast 特征:

switch(enable) set spantree portfast {module/port}{enable|disable} 19. 在基于IOS的交换机端口上启用或禁用UplinkFast 特征:

switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]

在基于CLI的交换机端口上启用或禁用UplinkFast 特征:

switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on] 20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令: switch(config)# cluster enable cluster-name 21. 为了从一条中继链路上删除VLAN,可使用下列命令:

switch(enable) clear trunk module/port vlan-range 22. 用show vtp domain 显示管理域的VTP参数. 23. 用show vtp statistics显示管理域的VTP参数. 24. 在Catalyst交换机上定义TrBRF的命令如下:

switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}] 25. 在Catalyst交换机上定义TrCRF的命令如下:

switch (enable) set vlan vlan-num [name name] type trcrf

{ring hex-ring-num|decring decimal-ring-num} parent vlan-num 26. 在创建好TrBRF VLAN之后,就可以给它分配交换机端口.对于以太网交换,可以采用如下命令给VLAN分配端口:

switch(enable) set vlan vlan-num mod-num/port-num 27. 命令show spantree显示一个交换机端口的STP状态. 28. 配置一个ELAN的LES和BUS,可以使用下列命令:

ATM (config)# interface atm number.subint multioint

ATM(config-subif)# lane serber-bus ethernet elan-name 29. 配置LECS:

ATM(config)# lane database database-name

ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address

ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address

ATM(lane-config-databade)# name … 30. 创建完数据库后,必须在主接口上启动LECS.命令如下:

ATM(config)# interface atm number

ATM(config-if)# lane config database database-name

ATM(config-if)# lane config auto-config-atm-address

31. 将每个LEC配置到一个不同的ATM子接口上.命令如下:

ATM(config)# interface atm number.subint multipoint

ATM(config)# lane client ethernet vlan-num elan-num 32. 用show lane server 显示LES的状态. 33. 用show lane bus显示bus的状态. 34. 用show lane database显示LECS数据库可内容. 35. 用show lane client显示LEC的状态. 36. 用show module显示已安装的模块列表. 37. 用物理接口建立与VLAN的连接:

router# configure terminal

router(config)# interface media module/port

router(config-if)# description description-string

router(config-if)# ip address ip-addr subnet-mask

router(config-if)# no shutdown 38. 用中继链路来建立与VLAN的连接:

router(config)# interface module/port.subinterface

router(config-ig)# encapsulation[isl|dotlq] vlan-number

router(config-if)# ip address ip-address subnet-mask 39. 用LANE 来建立与VLAN的连接:

router(config)# interface atm module/port

router(config-if)# no ip address

router(config-if)# atm pvc 1 0 5 qsaal

router(config-if)# atm pvc 2 0 16 ilni

router(config-if)# interface atm module/port.subinterface multipoint

router(config-if)# ip address ip-address subnet-mask

router(config-if)# lane client ethernet elan-num

router(config-if)# interface atm module/port.subinterface multipoint

router(config-if)# ip address ip-address subnet-name

router(config-if)# lane client ethernet elan-name

router(config-if)# … 40. 为了在路由处理器上进行动态路由配置,可以用下列IOS命令来进行:

router(config)# ip routing

router(config)# router ip-routing-protocol

router(config-router)# network ip-network-number

router(config-router)# network ip-network-number 41. 配置默认路由:

switch(enable) set ip route default gateway 42. 为一个路由处理器分配VLANID,可在接口模式下使用下列命令:

router(config)# interface interface number

router(config-if)# mls rp vlan-id vlan-id-num 43. 在路由处理器启用MLSP:

router(config)# mls rp ip 44. 为了把一个外置的路由处理器接口和交换机安置在同一个VTP域中:

router(config)# interface interface number

router(config-if)# mls rp vtp-domain domain-name 45. 查看指定的VTP域的信息:

router# show mls rp vtp-domain vtp domain name 46. 要确定RSM或路由器上的管理接口,可以在接口模式下输入下列命令:

router(config-if)#mls rp management-interface

10个常见cisco交换机的操作命令,并介绍其作用

1. 交换机支持的命令:

交换机基本状态:

switch: ;ROM状态, 路由器是rommon>hostname> ;用户模式hostname# ;特权模式hostname(config)# ;全局配置模式hostname(config-if)# ;接口状态

交换机口令设置: switch>enable ;进入特权模式switch#config terminal ;进入全局配置模式switch(config)#hostname ;设置交换机的主机名switch(config)#enable secret xxx ;设置特权加密口令switch(config)#enable password xxa ;设置特权非密口令switch(config)#line console 0 ;进入控制台口switch(config-line)#line vty 0 4 ;进入虚拟终端switch(config-line)#login ;允许登录switch(config-line)#password xx ;设置登录口令xxswitch#exit ;返回命令

交换机VLAN设置:

switch#vlan database ;进入VLAN设置switch(vlan)#vlan 2 ;建VLAN 2switch(vlan)#no vlan 2 ;删vlan 2switch(config)#int f0/1 ;进入端口1switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2switch(config-if)#switchport mode trunk ;设置为干线switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlanswitch(config-if)#switchport trunk encap dot1q ;设置vlan 中继switch(config)#vtp domain ;设置发vtp域名switch(config)#vtp password ;设置发vtp密码switch(config)#vtp mode server ;设置发vtp模式switch(config)#vtp mode clIEnt ;设置发vtp模式

交换机设置IP地址:

switch(config)#interface vlan 1 ;进入vlan 1switch(config-if)#ip address ;设置IP地址switch(config)#ip default-gateway ;设置默认网关switch#dir flash: ;查看闪存

交换机显示命令:

switch#write ;保存配置信息switch#show vtp ;查看vtp配置信息switch#show run ;查看当前配置信息switch#show vlan ;查看vlan配置信息switch#show interface ;查看端口信息switch#show int f0/0 ;查看指定端口信息

2. 路由器支持的命令:

路由器显示命令:

router#show run ;显示配置信息router#show interface ;显示接口信息router#show ip route ;显示路由信息router#show cdp nei ;显示邻居信息router#reload ;重新起动

路由器口令设置:

router>enable ;进入特权模式router#config terminal ;进入全局配置模式router(config)#hostname ;设置交换机的主机名router(config)#enable secret xxx ;设置特权加密口令router(config)#enable password xxb ;设置特权非密口令router(config)#line console 0 ;进入控制台口router(config-line)#line vty 0 4 ;进入虚拟终端router(config-line)#login ;要求口令验证router(config-line)#password xx ;设置登录口令xxrouter(config)#(Ctrl+z) ; 返回特权模式router#exit ;返回命令

路由器配置:

交换机命令(交换机命令switch>enable的作用)

router(config)#int s0/0 ;进入Serail接口router(config-if)#no shutdown ;激活当前接口router(config-if)#clock rate 64000 ;设置同步时钟router(config-if)#ip address ;设置IP地址router(config-if)#ip address second ;设置第二个IProuter(config-if)#int f0/0.1 ;进入子接口router(config-subif.1)#ip address ;设置子接口IProuter(config-subif.1)#encapsulation dot1q ;绑定vlan中继协议router(config)#config-register 0x2142 ;跳过配置文件router(config)#config-register 0x2102 ;正常使用配置文件router#reload ;重新引导

路由器文件操作:

router#copy running-config startup-config ;保存配置router#copy running-config tftp ;保存配置到tftprouter#copy startup-config tftp ;开机配置存到tftprouter#copy tftp flash: ;下传文件到flashrouter#copy tftp startup-config;下载配置文件ROM状态:

Ctrl+Break ;进入ROM监控状态

rommon>confreg 0x2142 ;跳过配置文件

rommon>confreg 0x2102 ;恢复配置文件

rommon>reset ;重新引导

rommon>copy xmodem: flash: ;从console传输文件

rommon>IP_ADDRESS=10.65.1.2 ;设置路由器IP

rommon>IP_SUBNET_MASK=255.255.0.0 ;设置路由器掩码

rommon>TFTP_SERVER=10.65.1.1 ;指定TFTP服务器IP

rommon>TFTP_FILE=c2600.bin ;指定下载的文件

rommon>tftpdnld ;从tftp下载

rommon>dir flash: ;查看闪存内容

rommon>boot ;引导IOS

静态路由:

ip route ;命令格式router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 ;静态路由举例router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 ;默认路由举例

动态路由:

router(config)#ip routing ;启动路由转发router(config)#router rip ;启动RIP路由协议。router(config-router)#network ;设置发布路由router(config-router)#negihbor ;点对点帧中继用。

华三交换机配置命令

华三交换机配置命令如下:

system-view

[H3C]super password H3C:设置用户分级密码

[H3C]undo super password:删除用户分级密码

[H3C]localuser bigheap 123456 1:Web网管用户设置,1(缺省)为管理级用户,缺admin,admin

[H3C]undo localuser bigheap:删除Web网管用户

[H3C]user-interface aux 0:只支持0

[H3C-Aux]idle-timeout 2 50:设置超时为2分50秒,若为0则表示不超时,默认为5分钟

[H3C-Aux]undo idle-timeout:恢复默认值

[H3C]user-interface vty 0:只支持0和1

[H3C-vty]idle-timeout 2 50:设置超时为2分50秒,若为0则表示不超时,默认为5分钟

[H3C-vty]undo idle-timeout:恢复默认值

[H3C-vty]set authentication password 123456:设置telnet密码,必须设置

[H3C-vty]undo set authentication password:取消密码

[H3C]display users:显示用户

[H3C]display user-interface:显示用户界面状态

扩展资料:

H3C Switch命令:

一、模式命令:

1、用户模式:Switch>

2、特权模式:Switch>enable

Switch#

3、全局配置模式:Switch#config terminal

Switch(config)#

4、接口配置模式:Switch(config)#interface fastethernet0/1

Switch(config-if)#

5、Line模式:Switch(config)#line console 0

Switch(config-line)#

二、特权模式下的命令:

1、查看机MAC地址:Switch#show mac-address-table

2、发现(CDP):

Switch#show cdp

Switch#show cdp interface fastethernet0/1

Switch#show cdp neighbors

Switch#show cdp neighbors detail

Switch#show cdp entry

工作原理:

交换机工作于OSI参考模型的第二层,即数据链路层。交换机内部的CPU会在每个端口成功连接时,通过将MAC地址和端口对应,形成一张MAC表。

在今后的通讯中,发往该MAC地址的数据包将仅送往其对应的端口,而不是所有的端口。因此,交换机可用于划分数据链路层广播,即冲突域;但它不能划分网络层广播,即广播域。

参考资料:百度百科—交换机

参考资料:百度百科—交换机命令

交换机的基本命令是什么?

“Switch>”

对于思科交换机来说,主要有2种配置途径:其一,使用交换机自带的Console线缆连接到计算机的COM口,然后利用计算机的超级终端软件直接配置,首次配置通常使用这种方式;其二,通过telnet方式远程访问、配置交换机,这种方式要求此交换机已配置有IP地址且已接入计算机网络。

1)通过超级终端访问交换机

2)交换机工作模式的进入与退出

步骤一:通过超级终端访问交换机。

1)配置并打开超级终端

在此前通过超级终端访问交换机实验拓扑环境中,单击PC机以打开此设备,确认电源已启动(机箱示意图上的指示灯为黄绿色),切换到“桌面选项卡”,找到其中的“终端”并单击打开。

在弹出的终端配置窗口中,如图-15所示,单击“确定”以接受默认值。

接下来就可以看到“终端”窗口了,其中显示了通过Console线连接的交换机初始化信息,回车后可进入交换机的“Switch>”配置系统。

提示:在Packet Tracer环境中,可直接单击交换机图标,然后切换到“命令行”选项卡,也可以进入IOS配置环境。

步骤二:交换机工作模式的进入与退出

1) 交换机工作模式的进入如下:

Switch>enable //切换为特权模式

Switch# configure terminal     //进入全局配置模式

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#interface fastEthernet 0/1 //进入接口模式

Switch(config-if)#

交换机的基本命令

交换机的基本命令有以下四种:

一、模式命令:

1. 用户模式:Switch>

2. 特权模式:Switch>enable

Switch#

3. 全局配置模式:Switch#config terminal

Switch(config)#

4. 接口配置模式:Switch(config)#interface fastethernet0/1

Switch(config-if)#

5. Line模式:Switch(config)#line console 0

Switch(config-line)#

二、特权模式下的命令:

1. 查看机MAC地址:Switch#show mac-address-table

2. 发现(CDP):

Switch#show cdp

Switch#show cdp interface fastethernet0/1

Switch#show cdp neighbors

Switch#show cdp neighbors detail

Switch#show cdp entry

3. 保存机配置:

Switch#copy running-config startup-config或者Switch#write

4. 恢复交换机出厂值:

Switch#erase startup-config

Switch#reload

三、全局配置模式下的命令:

1. 配置主机名:Switch(config)#hostname Sw1

Sw1(config)#

2、 设置登陆台密码:Switch(config)#line console 0

Switch(config-line)#password 密码

Switch(config-line)#login

3. 使能口令:Switch(config)#enable Password 密码

4. 加密保存的使能口令:Switch(config)#enable secret 密码

5. 配置IP地址:

Switch(config)#interface vlan 1

Switch(config-if)#ip address IP地址 网关

Switch(config-if)#no shutdown

6. 配置交换机网关:Switch(config)#ip default-gateway 网关

四、VLAN配置命令:

1. 创建vlan命令:

a) 全局配置模式下:

Switch(config)#vlan 2

Switch(config)#name v2

Switch(config)#mtu 数值

Switch(config)#end

b) Vlan数据库下:

Switch#vlan database

Switch#vlan 2 name v2

Switch#vlan 2 mut 数值

Switch#exit

2. 删除vlan命令:

a) 全局配置模式下:

Switch(config)#no vlan 2

Switch(config)#end

b) Vlan数据库下:

Switch#no vlan 2 name v2

Switch#exit

3. 在vlan中添加端口:

Switch#config terminal

Switch(config)#interface f0/1(端口)

Switch(config-if)#Switchport mode access

Switch(config-if)#switchport access vlan 2

Switch(config-if)#end

一次将多个端口添加到vlan中:

Switch#config terminal

Switch(config)#interface range f0/1 - 5(端口)

Switch(config-if)#switchport access vlan 2

Switch(config-if)#end

注:switch#show vlan biref(查看vlan信息)

4. 配置vlan trunk:

1. 配置接口为trunk命令:

Switch(config)# interface f0/1(端口)

Switch(config-if)#Switchport mode trunk

2. 配置接口为动态协商模式的命令:

Switch(config)# interface f0/1(端口)

Switch(config-if)#switchport mode dynamic desirable/auto

3. 从trunk中删除vlan:

Switch(config)# interface f0/1(端口)

Switch(config-if)#Switchport trunk allowed vlan remove 2

4. 在trunk中添加vlan:

Switch(config)# interface f0/1(端口)

Switch(config-if)#Switchport trunk allowed vlan add 2